Apache Tomcat 条件竞争漏洞

OSCS开源供应链安全
 OSCS开源供应链安全
发布于 2022年09月29日
收藏 0

漏洞描述

Tomcat 是由Apache软件基金会属下Jakarta项目开发的Servlet容器,实现了对Servlet和JavaServer Page的支持,并提供了作为Web服务器的一些特有功能。

由于 Tomcat 9.0.47及以后的版本中对阻塞读写的代码进行了简化处理,从而存在共享资源并发执行漏洞。攻击者可以利用此漏洞在 Client Connection Handler 组件中传入不合法输入导致客户端连接共享一个 Http11Processor 实例,从而导致部分或全部的响应被错误的客户端接收。

漏洞名称 Apache Tomcat 条件竞争漏洞
漏洞类型 竞争条件
发现时间 2022/9/29
漏洞影响广度 一般
MPS编号 MPS-2021-37218
CVE编号 CVE-2021-43980
CNVD编号 -

影响范围

org.apache.tomcat:tomcat@[10.0.0-M1, 10.0.20)

org.apache.tomcat.embed:tomcat-embed-core@[8.5.0, 8.5.78)

org.apache.tomcat.embed:tomcat-embed-core@[10.0.0-M1, 10.0.20)

org.apache.tomcat:tomcat@[8.5.0, 8.5.78)

org.apache.tomcat.embed:tomcat-embed-core@[9.0.0-M1, 9.0.62)

org.apache.tomcat.embed:tomcat-embed-core@[10.1.0-M1, 10.1.0-M14)

org.apache.tomcat:tomcat@[10.1.0-M1, 10.1.0-M14)

org.apache.tomcat:tomcat@[9.0.0-M1, 9.0.62)

修复方案

升级org.apache.tomcat:tomcat到 8.5.78 或 9.0.62 或 10.0.20 或 10.1.0-M14 或更高版本

升级org.apache.tomcat.embed:tomcat-embed-core到 8.5.78 或 9.0.62 或 10.0.20 或 10.1.0-M14 或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-2021-37218

https://nvd.nist.gov/vuln/detail/CVE-2021-43980

https://tomcat.apache.org/security-10.html

https://github.com/apache/tomcat/commit/17f177eeb7df5938f67ef9ea580411b120195f13

    

情报订阅

OSCS(开源软件供应链安全社区)通过最快、最全的方式,发布开源项目最新的安全风险动态,包括开源组件安全漏洞、事件等信息。同时提供漏洞、投毒情报的免费订阅服务,社区用户可通过配置飞书、钉钉、企业微信机器人,及时获得一手情报信息推送:

https://www.oscs1024.com/?src=osc

具体订阅方式详见:

https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Apache Tomcat 条件竞争漏洞
加载中
返回顶部
顶部