Apache Geode (Java8环境) 不受信任的反序列化漏洞

OSCS开源供应链安全
 OSCS开源供应链安全
发布于 2022年08月31日
收藏 1

漏洞描述

Apache Geode 是一个数据管理平台,可在广泛分布的云架构中提供对数据密集型应用程序的实时,一致的访问。

Apache Geode 的漏洞版本中存在不受信任的反序列化漏洞,在 Java 8上使用 JMX over RMI 时,攻击者可利用该漏洞执行任意代码,甚至接管服务器。

漏洞名称 Apache Geode (Java8环境) 不受信任的反序列化漏洞
漏洞类型 反序列化
发现时间 2022/8/31
漏洞影响广度 极小
MPS编号 MPS-2022-52738
CVE编号 CVE-2022-37021
CNVD编号 -

影响范围

org.apache.geode:geode-core@(∞, 1.12.6)

org.apache.geode:geode-core@[1.13.0, 1.13.5)

org.apache.geode:geode-core@[1.14.0, 1.14.1)

修复方案

升级org.apache.geode:geode-core到1.15.0或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-2022-52738

https://nvd.nist.gov/vuln/detail/CVE-2022-37021

https://www.openwall.com/lists/oss-security/2022/08/30/3

    

情报订阅

OSCS(开源软件供应链安全社区)通过最快、最全的方式,发布开源项目最新的安全风险动态,包括开源组件安全漏洞、事件等信息。同时提供漏洞、投毒情报的免费订阅服务,社区用户可通过配置飞书、钉钉、企业微信机器人,及时获得一手情报信息推送:

https://www.oscs1024.com/?src=osc

具体订阅方式详见:

https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Apache Geode (Java8环境) 不受信任的反序列化漏洞
加载中
返回顶部
顶部